Category: Vulnerability
-
Apple iOS 18 and iPadOS 18 security vulnerability (CVE-2024-44207)
CVE-2024-44207 is a vulnerability in Apple’s iOS and iPadOS systems, impacting versions prior to 18.0.1. This flaw in the Messages app allows audio messages to capture brief audio snippets before the microphone indicator is turned on, potentially exposing sensitive information. This issue is fixed in iOS 18.0.1 and iPadOS 18.0.1. See more details on:
-
NVIDIA security vulnerability (CVE-2024-0132)
CVE-2024-0132 is a critical vulnerability in NVIDIA Container Toolkit (versions 1.16.1 and earlier) and NVIDIA GPU Operator (versions 24.6.1 and earlier). It is classified as a Time-of-Check Time-of-Use (TOCTOU) issue, which could allow an attacker to exploit a flaw in how the container runtime accesses resources, potentially gaining access to the host file system through…
-
FreeBSD security vulnerability (CVE-2024-41721)
CVE-2024-41721 refers to a vulnerability in FreeBSD’s USB subsystem, specifically related to the XHCI (eXtensible Host Controller Interface) emulation in the bhyve hypervisor. The flaw arises from insufficient boundary validation, leading to an out-of-bounds read on the heap. This vulnerability can potentially allow an attacker to perform arbitrary writes and execute remote code. Affected versions…
-
Red Hat OpenShift Container Platform vulnerability (CVE-2024-45496)
CVE-2024-45496 is a critical security vulnerability affecting Red Hat’s OpenShift Container Platform, with a CVSS score of 9.9. The vulnerability stems from improper privilege management during the build process, specifically in the git-clone container. This container is run with elevated privileges, allowing an attacker with developer-level access to insert a malicious .gitconfig file during the…
-
FreeBSD security vulnerability (CVE-2024-43102)
CVE-2024-43102 is a critical vulnerability affecting FreeBSD, specifically related to the improper handling of anonymous shared memory mappings in the kernel. This vulnerability is tied to the UMTX_SHM_DESTROY operation within the UMTX_OP_SHM API. If exploited, it can lead to a premature freeing of memory, which may result in a kernel panic or enable further “use-after-free”…
-
CVE-2024-45492
CVE-2024-45492 is a critical vulnerability found in the widely used libexpat XML parsing library, specifically affecting versions prior to 2.6.3. This flaw originates from an integer overflow in the `nextScaffoldPart` function in 32-bit systems. Attackers can exploit this vulnerability to remotely execute arbitrary code or cause a denial of service, making it especially dangerous. It…
-
CVE-2024-45491
The CVE-2024-45491 vulnerability is an integer overflow issue identified in libexpat versions prior to 2.6.3. This vulnerability occurs in the `dtdCopy` function of the `xmlparse.c` file, specifically impacting 32-bit platforms. The problem arises when an attacker can exploit this overflow in systems where `UINT_MAX` equals `SIZE_MAX`. The vulnerability is critical, with a CVSS score of…
-
CVE-2024-45490
The CVE-2024-45490 vulnerability is a security flaw identified in versions of the Expat library (specifically libexpat) prior to version 2.6.3. The vulnerability occurs in the xmlparse.c file, which is responsible for parsing XML data. The issue arises when the function XML_ParseBuffer fails to reject negative lengths during buffer parsing. This oversight can potentially lead to…
-
Windows TCP/IP Remote Code Execution Vulnerability (CVE-2024-38063)
A critical security vulnerability identified as CVE-2024-38063 has been discovered in the Windows TCP/IP stack, affecting all supported versions of Windows and Windows Server, including Server Core installations. This vulnerability allows remote code execution (RCE) without user interaction, classifying it as a zero-click exploit. The flaw, which Microsoft has rated as critical with a CVSS…
-
Zabbix vulnerability – Remote code execution within ping script (CVE-2024-22116)
CVE-2024-22116 is a critical arbitrary code execution vulnerability in Zabbix Server. This vulnerability affects versions 6.4.0 to 6.4.15 and 7.0.0alpha1 to 7.0.0rc2. The issue stems from improper control over script parameters in the Ping script execution feature within the Monitoring Hosts section of Zabbix Server. Attackers with restricted administrative privileges can exploit this vulnerability to…
-
Zscaler security vulnerability (CVE-2024-23483)
CVE-2024-23483 is a vulnerability identified in the Zscaler Client Connector on macOS systems running versions below 4.2. It is categorized as an OS command injection flaw, stemming from improper input validation. The vulnerability allows remote attackers to exploit the lack of safeguards by injecting OS commands, potentially enabling unauthorized access and control over the affected…
-
VMware ESXi Authentication Bypass Vulnerability (CVE-2024-37085)
CVE-2024-37085 is an authentication bypass vulnerability in VMware ESXi. It allows a malicious actor with sufficient Active Directory (AD) permissions to gain full administrative access to an ESXi host. This vulnerability occurs when an attacker re-creates or renames an AD group to match the default ESXi group name (“ESXi Admins”), enabling unauthorized access. The group…